If you have problems using SVN with Eclipse…


make sure that you’ve installed the JavaHL Adapter. Otherwise you will get messages saying:

Unable to load default SVN Client

JavaHL seems to be the actual bingding to the Subversion, so it is really a mystery to me why it isn’t marked as a dependency for subeclipse… Related blogposts which pointed me in the right direction:

PS. Subversion is is nicely integrated into Eclipse if you install subeclipse and I think that it should be in core, replacing CVS as the default or at least complementing it… One of my biggest pet peeves with CVS at the moment is that it doesn’t have the “one commit – one unit of work” mentality and I have to perform all sorts of logparsing voodoo to answer questions like “what files were changed by commit X”?

, ,

Leave a Reply

Your email address will not be published.